Forum - View topic
Image-loading problems in the forums


Goto page Previous  1, 2, 3, 4

Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions
View previous topic :: View next topic  
Author Message
Touma



Joined: 29 Aug 2007
Posts: 1026
Location: Colorado, USA

PostPosted: Fri Apr 18, 2014 12:19 pm Reply with quote
It is definitely true that they do not need to give an explanation, and if they do not I will certainly not complain.

But still, I hope that they can say something.
I have never seen a problem like this before and I would like to have some idea of what caused it in case I encounter it again somewhere.
Back to top
View user's profile Send private message My Anime My Manga
Blood-
SubscriberSubscriber


Joined: 07 Mar 2009
Posts: 14576
Location: Toronto, Canada

PostPosted: Fri Apr 18, 2014 1:03 pm Reply with quote
TsunaReborn! wrote:
mdo7 wrote:
Tony K. wrote:
It's magic. Waah~ (*waves hands in a mystical manner in front of screen*).


LOL. LaughingLaughingLaughing

Anyway, really happy to see this fixed, I wish Dan42 or Tempest could give an explanation what happened?? Confused


I don't think they really need to, these things happen. It's fixed, happy days Very Happy


Can we not do this please? Hey, it's awesome you don't want any information, but some of us are curious. Let's not enable bad customer service, please. Standard operating procedure in situations like this would be for a company representative to give a brief explanation of what went wrong and some indication of how something like this will be avoided in the future.
Back to top
View user's profile Send private message My Anime My Manga
TsunaReborn!
Enjoying the time of EVEEnjoying the time of EVE


Joined: 08 Sep 2012
Posts: 3413
Location: Cheltenham UK

PostPosted: Fri Apr 18, 2014 1:42 pm Reply with quote
Blood- wrote:
Can we not do this please? Hey, it's awesome you don't want any information, but some of us are curious.


What am I doing? Confused

Oh I'm not saying information shouldn't be given - I read mdo7's "wish" as a demand rather than when I reread the way it was intended.
Back to top
View user's profile Send private message My Anime My Manga
mdo7



Joined: 23 May 2007
Posts: 4109
Location: Maryland, USA

PostPosted: Fri Apr 18, 2014 4:11 pm Reply with quote
TsunaReborn! wrote:
Blood- wrote:
Can we not do this please? Hey, it's awesome you don't want any information, but some of us are curious.


What am I doing? Confused

Oh I'm not saying information shouldn't be given - I read mdo7's "wish" as a demand rather than when I reread the way it was intended.


Actually I agreed with Blood-, we the people of ANN have the right to know what happen. I don't want any cover-up or anything like that.
Back to top
View user's profile Send private message
nbahn
Anime isn't real? Nooo...Anime isn't real? Nooo...


Joined: 14 Dec 2006
Posts: 1855
Location: Now in Great Lakes region

PostPosted: Fri Apr 18, 2014 4:33 pm Reply with quote
Touma wrote:
It is definitely true that they do not need to give an explanation, and if they do not I will certainly not complain.

But still, I hope that they can say something.
I have never seen a problem like this before and I would like to have some idea of what caused it in case I encounter it again somewhere.

+1
(couldn't have said it better myself)
Back to top
View user's profile Send private message My Anime My Manga
errinundra
Enjoying the time of EVEEnjoying the time of EVE


Joined: 14 Jun 2008
Posts: 2627
Location: Melbourne, Oz

PostPosted: Fri Apr 18, 2014 6:19 pm Reply with quote
It ISN'T working for me on Firefox. (I'm posting this using my non-preferred IE.) Perhaps the .au version still needs fixing?
Back to top
View user's profile Send private message Send e-mail My Anime My Manga
dtm42



Joined: 05 Feb 2008
Posts: 12662
Location: NZL

PostPosted: Sat Apr 19, 2014 1:33 am Reply with quote
^
Firefox works for me.

Try using the .com version of the site and see what happens.

If you can't, trying using either of these:

www-d.animenewsnetwork.com
http://4nn.cx/​us

I dunno if they will work, but they might. *shrugs*
Back to top
View user's profile Send private message My Anime
Blanchimont



Joined: 25 Feb 2012
Posts: 352

PostPosted: Sat Apr 19, 2014 6:29 am Reply with quote
@errinundra

I did some tests on the Australian site.

(Note; Trying to go there with the option given in the dropdown menu above doesn't work, it just ends up back here in the .com version. Though not sure if it's the same for others or just one of my addons preventing it?)

If I go to the .au site in firefox(v28), the front page seems to work fine (provided you make an exception in NoScript).
Now, going to the forums, you're however presented with the same issue as the rest of us yesterday (no quote/avatars/last posts links).
Nor does the trick given for Chrome earlier in this thread work (ie reloading/opening in new tab/back/forward).

There seems to be a workaround for this though (at least for me on this version of firefox and in my geographic location(Finland)(servers used seem to differ between regions, mine is using ruka-chan)).

Go to the thread page you want to post on. Then go to firefox file menu and choose 'Save Session and Exit'.
(Might need an addon(Save Session), not sure if there's a similar option inherent in firefox?)

Once you run firefox again, the page you chose should display avatars/quotes links.
(Forgot to check if that also carries over to the reply-page?..)

Also, this might be unrelated, but when I first tried to enter a forum thread on the .au version, it wouldn't redirect properly, instead ending in an infinite loop.
So I looked at my addons and enabled NoRedirect (which I had forgotten to turn on after checking this site yesterday). and entering forum threads worked now fine.
Hovever I did a new test by disabling NoRedirect again, and this time there were no issues entering those threads even without it. So it might have been only a temporary glitch unrelated to this...
Back to top
View user's profile Send private message
errinundra
Enjoying the time of EVEEnjoying the time of EVE


Joined: 14 Jun 2008
Posts: 2627
Location: Melbourne, Oz

PostPosted: Sat Apr 19, 2014 7:31 am Reply with quote
Blanchimont, I got the save session add-on, however it doesn't seem to make a difference.

dtm42, your suggested link works nicely, albeit I'm logged onto the US site, rather than the Oz site. I can live with that. I'd rather do that with Firefox than the Oz site with IE.

Thanks for the help, guys.
Back to top
View user's profile Send private message Send e-mail My Anime My Manga
Blanchimont



Joined: 25 Feb 2012
Posts: 352

PostPosted: Sat Apr 19, 2014 8:32 am Reply with quote
errinundra wrote:
Blanchimont, I got the save session add-on, however it doesn't seem to make a difference.


This.. is strange...

It works. But... it only works if you DON'T make an exception in NoScript for the .au.

To be more precise, if I go to this forum thread in firefox on .au, first time they won't show. Exit browser and reload session, and it works.
But ONLY if .au is "blocked" in NoScript.

If you see this post it means I posted it successfully from the .au side(server seems to still be ruka-chan).

Though the fact the site needs to be blocked in NoScript for it to work means some site features won't work/show, and bbcode tags need to be manually inserted...
Back to top
View user's profile Send private message
dtm42



Joined: 05 Feb 2008
Posts: 12662
Location: NZL

PostPosted: Sat Apr 19, 2014 3:44 pm Reply with quote
errinundra wrote:
Thanks for the help, guys.


No problem. I got those links a while back from a good Samaritan (whose name I unfortunately cannot recall), so it's only natural that I repay the favour by helping someone else in return.
Back to top
View user's profile Send private message My Anime
Dan42
Chief Encyclopedist


Joined: 02 Jan 2002
Posts: 3223
Location: Montreal

PostPosted: Sun Apr 20, 2014 9:35 pm Reply with quote
Post-mortem:

I was away for the weekend so I had no idea this was going on, but apparently it was caused by an Cloudflare "optimization" feature we turned on. We're not exactly sure what happened but when Tempest turned it off it fixed the site, so I think we're justified in blaming it.

This Mirage 2 feature was supposed to make the site faster on mobile devices by avoiding to load unnecessary images. Well, it sure avoided loading images. Anywhere. On any device.

Moral of the story: don't believe a sales pitch that says it will magically make your site faster :-/

m(_ _)m
Back to top
View user's profile Send private message Visit poster's website AIM Address My Anime My Manga
dtm42



Joined: 05 Feb 2008
Posts: 12662
Location: NZL

PostPosted: Sun Apr 20, 2014 10:42 pm Reply with quote
Dan42 wrote:
This Mirage 2 feature was supposed to make the site faster on mobile devices by avoiding to load unnecessary images. Well, it sure avoided loading images. Anywhere. On any device.

Moral of the story: don't believe a sales pitch that says it will magically make your site faster :-/


Now that the situation has been over for a couple of days and things have calmed down, I can actually see the ironic humour in a product which works too well. And it's a relief that it was easy to fix.
Back to top
View user's profile Send private message My Anime
mdo7



Joined: 23 May 2007
Posts: 4109
Location: Maryland, USA

PostPosted: Sun Apr 20, 2014 11:19 pm Reply with quote
Thanks for the explanation, Dan42. Feel much better after reading your message. Very Happy
Back to top
View user's profile Send private message
DerekTheRed
Encyclopedia SupporterEncyclopedia Supporter


Joined: 19 Dec 2007
Posts: 3271
Location: ::Points to hand::

PostPosted: Sun Apr 20, 2014 11:50 pm Reply with quote
So, the reason IE still worked right was that Mirage 2 didn't work right on IE? Laughing
Back to top
View user's profile Send private message My Anime My Manga
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions All times are GMT - 5 Hours
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 


Powered by phpBB © 2001, 2005 phpBB Group