Forum - View topic
Links no longer work?




Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions
View previous topic :: View next topic  
Author Message
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Fri Dec 02, 2016 6:40 pm Reply with quote
I visited the site like I do everyday and noticed that the format the news was displayed to me was tiled (which I changed a long time ago and it always stuck). I really hate that format, so I clicked the icon for the image & lines and… nothing. I can hover over the icon and it displays the alt text, but clicking on it does nothing.

I ended up trying to click on other things and none of the links in the blue bar (where the news, encyclopedia, view, etc are listed) work for me. No right-click, no alt text, nothing.

Is this happening only for me? Was there a change recently? I could access the encyclopedia section just a day ago. Had to get to the forums via an article (at least clicking on the articles gets me to the stories).
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Fri Dec 02, 2016 7:07 pm Reply with quote
I did not try changing my display, but all of the navigation links work for me.

Does your browser have a script blocker such as NoScript?
If so make sure that it is not blocking scripts on this site.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
Errinundra
Moderator


Joined: 14 Jun 2008
Posts: 4513
Location: Melbourne, Oz
PostPosted: Fri Dec 02, 2016 7:40 pm Reply with quote
They're fine on my PC, but screwed on my mobile device. With the latter I also can't access the drop down menus across the top of the page & the pages don't resize to fit the screen.
Back to top
View user's profile Send private message Send e-mail Visit poster's website My Anime My Manga
unready



Joined: 07 Jun 2009
Posts: 322
Location: Illinois, USA
PostPosted: Sat Dec 03, 2016 1:16 am Reply with quote
There has been a JavaScript change. My console says, for example on the main page:
Quote:
in strict mode code, functions may be declared only at top level or immediately within another function @ animenewsnetwork.com/assets/b9fc74d84a336742de7b0a13bd223c1c986fcae7.js:121
ANN is not defined @ animenewsnetwork.com/:28
J is not defined @ animenewsnetwork.com/:6929
ANN is not defined @ animenewsnetwork.com/:7007


The only way I was able to log in just now was to copy the site's JavaScript to Scratchpad, remove "use strict", and run it again. So if you're using a device or browser that doesn't support strict mode (like some older versions of IE), chances are the site works for you. Otherwise you need to be a hacker to figure out how to get past the broken code.
Back to top
View user's profile Send private message My Anime
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Sat Dec 03, 2016 8:20 pm Reply with quote
unready wrote:
There has been a JavaScript change. My console says, for example on the main page:
Quote:
in strict mode code, functions may be declared only at top level or immediately within another function @ animenewsnetwork.com/assets/b9fc74d84a336742de7b0a13bd223c1c986fcae7.js:121
ANN is not defined @ animenewsnetwork.com/:28
J is not defined @ animenewsnetwork.com/:6929
ANN is not defined @ animenewsnetwork.com/:7007


The only way I was able to log in just now was to copy the site's JavaScript to Scratchpad, remove "use strict", and run it again. So if you're using a device or browser that doesn't support strict mode (like some older versions of IE), chances are the site works for you. Otherwise you need to be a hacker to figure out how to get past the broken code.


Thanks, I wonder if the site admin is aware of this?
Back to top
View user's profile Send private message
Sailor S



Joined: 20 May 2009
Posts: 2942
PostPosted: Sat Dec 03, 2016 8:40 pm Reply with quote
So, to be actually helpful, I can tell you from firsthand experience that I had the same problem you did. I was using Firefox. I updated to the latest version, and now I don't have those problems. Hope this helps more than anyone else did.
Back to top
View user's profile Send private message My Anime My Manga
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Sat Dec 03, 2016 9:03 pm Reply with quote
Sailor S wrote:
So, to be actually helpful, I can tell you from firsthand experience that I had the same problem you did. I was using Firefox. I updated to the latest version, and now I don't have those problems. Hope this helps more than anyone else did.


Thanks. Well, I guess I can't use ANN anymore. I have an older OS (because I need certain software) and can't upgrade FF anymore. I am on a version released earlier this year though.

That sucks. Sad
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sat Dec 03, 2016 10:18 pm Reply with quote
sdsichero wrote:
can't upgrade FF anymore. I am on a version released earlier this year though.

What version are you using?
I have 47.0 (I think that the latest is 50) on Windows 7 and everything works for me, so far.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
Top Gun



Joined: 28 Sep 2007
Posts: 2790
PostPosted: Sun Dec 04, 2016 7:54 pm Reply with quote
Can confirm that things are all kinds of broken on Pale Moon 27.0.2.
Back to top
View user's profile Send private message
Dan42
Chief Encyclopedist


Joined: 02 Jan 2002
Posts: 3529
Location: Montreal
PostPosted: Sun Dec 04, 2016 10:26 pm Reply with quote
Whoa. Ok, I uploaded a fix. It's very surprising though, Chrome v49 does *not* complain about anything broken. I would never expect the Javascript interpreter to be buggy in a browser version released only one year ago.

Thanks to unready for the detailed error message with backtrace, otherwise this would have been very thorny to debug.
Back to top
View user's profile Send private message Visit poster's website AIM Address My Anime My Manga
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Mon Dec 05, 2016 12:14 am Reply with quote
Dan42 wrote:
Whoa. Ok, I uploaded a fix. It's very surprising though, Chrome v49 does *not* complain about anything broken. I would never expect the Javascript interpreter to be buggy in a browser version released only one year ago.

Thanks to unready for the detailed error message with backtrace, otherwise this would have been very thorny to debug.

Thanks so much for the fix (thanks also to unready)! It works now.

Sorry for all the trouble. Sad
Back to top
View user's profile Send private message
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Wed Aug 02, 2017 6:15 pm Reply with quote
Looks like this is happening again for me. Stuck in the grid view (which to me is hard to read). None of the links near the top (All • Anime Manga Novels Games Music Merch Events Industry People Live-Action) nor the view buttons work. Also the slideshow doesn't display. Was there a change to the site again?
Back to top
View user's profile Send private message
sdsichero



Joined: 15 Oct 2009
Posts: 66
PostPosted: Thu Aug 03, 2017 7:35 pm Reply with quote
Okay now the articles are listed like how I prefer it (list with pictures), but the links near the top (News Views New Anime Encyclopedia Forum MyANN About) do not work. My cursor does not even change when mousing over them.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions All times are GMT - 5 Hours
Page 1 of 1

 


Powered by phpBB © 2001, 2005 phpBB Group