Forum - View topic
embedded youtube-nocookie links in News


Goto page 1, 2  Next

Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions
View previous topic :: View next topic  
Author Message
configspace



Joined: 16 Aug 2008
Posts: 3713
PostPosted: Fri Mar 06, 2015 5:31 am Reply with quote
I noticed all the recent News articles with embedded youtube videos reference youtube-nocookie.com instead of youtube.com. For me and a couple others I've seen, it results in an error.

For example:
animenewsnetwork.com/news/2015-03-06/kyoto-animation-sound-euphonium-tv-ad-reveals-premiere-date/.85682

The two video links are:
https://www.youtube-nocookie.com/watch?v=DhU8qO-qDhM
https://www.youtube-nocookie.com/watch?v=Q9K39h910EQ
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Fri Mar 06, 2015 9:47 am Reply with quote
^
I do not know what it means but when I go to that page, using the link in your post, the videos that I see are at:
https://www.youtube.com/watch?v=DhU8qO-qDhM
https://www.youtube.com/watch?v=Q9K39h910EQ

Maybe which link you get depends on which server you are on here? I am on the regular moeka-chan server.

EDIT:
I clicked on the video URLs in your post here and got "404 not found" errors for both of them.
Is that the problem that you are having?

I do get the correct video when I delete "-nocookie" from the URL.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
configspace



Joined: 16 Aug 2008
Posts: 3713
PostPosted: Sat Mar 07, 2015 2:13 am Reply with quote
Thanks for checking it out. I don't know if it's on my end. youtube-nocookie.com apparently Google's own service too.

Firefox browser console shows I'm getting it from server "cloudflare-nginx"

It's part of the source sent to me at least from a GET of the .85682 file in the url:
Code:

<DOCTYPE>
<html>
 <head><script>
//<CDATA>
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:0,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"a293ea43c8d52671043127a1d61fffc5",petok:"20647ed5284ff1f45bb80be8d014a75bd1cbb345-1425711579-1800",zone:"animenewsnetwork.com",rocket:"0",apps:{"abetterbrowser":{"ie":"6"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=919620257c/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>

......

<div>
{iframe width="640" height="360" src="//www.youtube-nocookie.com/embed/DhU8qO-qDhM?rel=0" frameborder="0" allowfullscreen></iframe}
</div>
<p>
</p>
<blockquote>
Teacher: New students, welcome to Kitauji High School!<br>
Kumiko: Oh, it's the brass band club!<br>
Reina: We weren't aiming for the nationals.<br>
......


I had to replace the angled brackets in the iframe tag above to get it to show. All of the scripts are missing too. Also, I had to fill out a captcha by cloudflare to post this originally.
Back to top
View user's profile Send private message
Dessa



Joined: 14 Jul 2004
Posts: 4434
PostPosted: Sat Mar 07, 2015 10:25 am Reply with quote
In Chrome, it works fine. However, I just tried it in Firefox, and I get the same problem with the nocookies. So I think it may be a problem with your settings in Firefox.

I checked my privacy settings (Tools > Options > Privacy) and in the second box for History, I had it set to "Remember History", but even selecting "Use custom settings for history", it says I'm set to accept cookies. So I'm not sure why the redirect to nocookie, and my feeble google-fu is not revealing anything on why it might.

But it definitely seems like it's a Firefox issue.
Back to top
View user's profile Send private message My Anime
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sat Mar 07, 2015 11:00 am Reply with quote
Dessa wrote:
So I think it may be a problem with your settings in Firefox.

I think that "Tracking" in the privacy setting is the most likely culprit. This is separate from the "History" setting.

I am set to allow tracking and have no problems with the video URL.
I would change the setting to see if I develop the problem, but I am afraid that it might do something to my stored cookies.

I am guessing that the "-nocookie" URL is the equivalent of a "your browser cannot accept cookies" message.
If so, I think that the message would have been the better option.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
Parse Error



Joined: 09 Oct 2009
Posts: 590
PostPosted: Sat Mar 07, 2015 11:38 am Reply with quote
The youtube-nocookie.com is coded into the page and is the same when viewing source in browsers where it works. At first I assumed it would be a protocol issue caused by loading the site over https, but after messing around for a while it turned out it doesn't seem to make any difference either way. I tried clearing browser, Flash, and DNS caches to avail, then restarted Firefox (well, Waterfox, but same difference) in safe mode to check if the issue was caused by one or more add-ons, but had no luck with that either. The videos work fine in everything else, so I must have had a different browser open when I originally watched them.
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sat Mar 07, 2015 11:56 am Reply with quote
Parse Error wrote:
The youtube-nocookie.com is coded into the page and is the same when viewing source in browsers where it works.

So it is.
I still think that it works for me because of my settings in Firefox.
Allowing tracking might remove the "-nocookie" from the URL.

If that is the case then it seems to me that either "-nocookie" should not be in the URL or Youtube is supposed to have a video file at that URL, but they do not.

Something that I just read makes me think that this nocookie thing is a new YouTube "feature."
EDIT: After further reading at cnet I am pretty sure that the problem here is caused by YouTube not having the video files where they should be.

EDIT 2: It occurs to me that the videos might work for me because of the settings for my YouTube account, rather than the Firefox settings.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
configspace



Joined: 16 Aug 2008
Posts: 3713
PostPosted: Sun Mar 08, 2015 12:12 am Reply with quote
For my settings, I allowed tracking and all cookies. I tried deleting all youtube and Google cookies, but no luck. I also tried creating a new profile in Firefox, so it has default settings, no add-ons, not logged into google/youtube/or any service, and still does not work.

I noticed Internet Explorer does work. But there, it's not using -nocookie when you click on the title link open the video url. Also I noticed that IE uses the HTML5 player and not flash. I'm guessing that Chrome also uses the HTML5 player.

I don't know if it makes a difference though, but even when I set youtube to use HTML5 https://www.youtube.com/html5 the embedded video links still use Flash. It's only when I go to youtube and play a video there does it use HTML5.


@Touma, in your Firefox, does the embedded video in the article use Flash or HTML5? You can check by right clicking on the video and the menu will be different.

Also, does the source html sent to you still contain the -nocookie embedded link? You can check by "View Page Source" and ctrl+f to search.

edit:
I found out how to make it work: Disable the Flash Plugin in Firefox Confused
That way it forces the embedded video to use HTML5 and somehow that makes a difference

Both profiles (Flash enabled & Flash disabled) gives me the same page with the nocookie link in the iframe:
Code:
src="//www.youtube-nocookie.com/embed/DhU8qO-qDhM?rel=0"


But the Flash-enabled profile gives me this URL when I click on the video title in the embedded video to open in youtube directly:
https://www.youtube-nocookie.com/watch?v=DhU8qO-qDhM

Where as the Flash-disabled profile gives me this URL:
https://www.youtube.com/watch?v=DhU8qO-qDhM

However even with Flash enabled, if I open use iframe src= path directly, it works!
http://www.youtube-nocookie.com/embed/DhU8qO-qDhM?rel=0

edit2:
I tried this on my Linux machine with Firefox + Flash and it's the same problem (unless I manually paste the "... embed/DhU8qO-qDhM?rel=0" link above) Disabled Flash plugin, reload and it works.
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sun Mar 08, 2015 11:34 am Reply with quote
configspace wrote:
@Touma, in your Firefox, does the embedded video in the article use Flash or HTML5?

I get the HTML5 player.

Quote:
Also, does the source html sent to you still contain the -nocookie embedded link?

The source for the ANN page does have -nocookie.
But when I use "Get video URL" or "Get embed code" for the HTML5 player they do not have -nocookie.

Quote:
I found out how to make it work: Disable the Flash Plugin in Firefox Confused
That way it forces the embedded video to use HTML5 and somehow that makes a difference

My Flash plugin is, and always has been, enabled and set to "Always Activate."
I still get the HTML5 player

I believe that this is a YouTube problem. They either do not have the -nocookie video files where they should be, or they have a mistake in the URL.
But there is also some contributing factor involved, and I do not know what , or where, it is.
That unknown factor is why the videos have always worked for me when they have not worked for others.

EDIT:
For what it's worth I just noticed that with the video URL the difference between what works for me and what gets the 404 error is that the one that works has "/embed/" in the URL and the one that does not work has "watch?v=" in place of that.
That is with "-nocookie" also in the URL.

Without "-nocookie" "embed" and "watch" both work.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
configspace



Joined: 16 Aug 2008
Posts: 3713
PostPosted: Sun Mar 08, 2015 12:06 pm Reply with quote
Appreciate the troubleshooting and additional data.

One more thing I'd like to check with you:
With Flash enabled, if you switch back to flash by choosing "Use the default player": https://www.youtube.com/html5
and reload the page so the embedded video uses Flash instead, does it still work for you?
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sun Mar 08, 2015 12:28 pm Reply with quote
configspace wrote:
if you switch back to flash by choosing "Use the default player": https://www.youtube.com/html5

Sorry, but I do not see that option.
I see a message telling me "The HTML5 player is currently used when possible" but there is no way to change that.
The only setting that I see on that page are for language, countey, and "safety."

That page also tells me that my browser supports everything except "MSE & WebM VP9 ", which I have never even heard of.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
octopodpie
ANN Managing Editor


Joined: 02 May 2011
Posts: 1984
Location: Washington State
PostPosted: Sun Mar 08, 2015 3:13 pm Reply with quote
It's a YouTube embed feature.

Go to "Share" then "embed" on a YouTube video. Click "enable privacy-enhanced mode." That's what we select before embedding a video into our articles.

It isn't a new feature, insomuch as it's existed for two or so years.

There's more information if you click the [?] next to the box
https://support.google.com/youtube/answer/171780?expand=PrivacyEnhancedMode#privacy
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sun Mar 08, 2015 3:54 pm Reply with quote
octopodpie wrote:
It's a YouTube embed feature.

I hope that by "it" you mean "-nocookie", and not the error that we are discussing.Smile

Quote:
It isn't a new feature, insomuch as it's existed for two or so years.

Thank you.
I should have noticed that the C/NET article that I was reading yesterday was written six years ago, but somehow I did not. Embarassed
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
configspace



Joined: 16 Aug 2008
Posts: 3713
PostPosted: Sun Mar 08, 2015 9:19 pm Reply with quote
Touma wrote:
configspace wrote:
if you switch back to flash by choosing "Use the default player": https://www.youtube.com/html5

Sorry, but I do not see that option.
I see a message telling me "The HTML5 player is currently used when possible" but there is no way to change that.
The only setting that I see on that page are for language, countey, and "safety."

Are you running Firefox on OSX or Win8+?

octopodpie wrote:
It's a YouTube embed feature.

Go to "Share" then "embed" on a YouTube video. Click "enable privacy-enhanced mode." That's what we select before embedding a video into our articles.

Thanks for the info. I can use that for some inquiries or bug reports.
Back to top
View user's profile Send private message
Touma



Joined: 29 Aug 2007
Posts: 2651
Location: Colorado, USA
PostPosted: Sun Mar 08, 2015 10:20 pm Reply with quote
^
I am running Firefox 37.0 beta on Windows7 sp1 64 bit.
Back to top
View user's profile Send private message Visit poster's website My Anime My Manga
Display posts from previous:   
Reply to topic    Anime News Network Forum Index -> Site-related -> Bugs & Technical Questions All times are GMT - 5 Hours
Goto page 1, 2  Next
Page 1 of 2

 


Powered by phpBB © 2001, 2005 phpBB Group